Welcome Guest [Log In] [Register]
GW2Navi Guild Wars 2 Overlay; Information, download, and discussion
Topic Started: Sunday, 13. July 2014, 08:03 (278,990 Views)
Drant
Member Avatar

The WvW live map is from another website, wvwintel.com, not gw2timer.com. That's why there's no GPS.

I've yet to add the WvW map to the website. If more people want it then I'll add it.

Edit: As of 2016-01-15, gw2timer.com has a WvW live map with GPS and overlay compatibility. Click on the Posted Image icon on the map to switch to the WvW map.
Offline Profile Quote Post Goto Top
 
Guest
Unregistered

If you add my character position on the WvW map, I'll donate $20. Honest to god ☺
Quote Post Goto Top
 
Schrubbii
Unregistered

Downloaded everything. When I try to start it, 3 new processes are generated in my Taskmanager and disappear like 2secs later. Rightclick -> Run As doesnt work any better... Ideas?
Quote Post Goto Top
 
Drant
Member Avatar

Did you download the latest Java version in your OS? The GW2Navi_Win32.jar and GW2Navi_Win64.jar files correspond to the x86 and x64 version of Java you installed. You could read the earlier posts about running .jar files. What is your operating system and bit version? And what Java version did you install?

Keep posting if you need more help.
Offline Profile Quote Post Goto Top
 
Guest
Unregistered

The overlay appears properly on all windows except for the actual game client. Any idea what I'm doing wrong?
Quote Post Goto Top
 
Drant
Member Avatar

Set your Resolution to Windowed Fullscreen like so: http://i.imgur.com/DO8Bf5p.png
Offline Profile Quote Post Goto Top
 
Azuredream
Unregistered

Hello!
Awesome tool from the look of it. But its window looking all messy for me. 32-bit version, 64 won't work.
http://ipic.su/img/img7/fs/navi.1434125783.jpg - screenshot.
Please, help. Java is latest version.
Quote Post Goto Top
 
Drant
Member Avatar

What operating system are you using? Windows XP/7/8/10? (Windows XP is not supported, and I only tested it in Windows 7).

The window bar should not look like that; the 1234AB icons should be visible and the background should be the same color as the rest of the bar, not gray.

My guess why the webpage is displayed like that is because your Internet Explorer is too old (the overlay embeds your Internet browser to display the website). You'll need to update it to version 11.

Keep posting and I'll help you.
Offline Profile Quote Post Goto Top
 
Azuredream
Unregistered

You know... I updated IE to 11, and it started to look normally. Although menu (upper part of the window, above address) is still invisible, like in my first screenshot. But at least it tracks me, and so on.
Quote Post Goto Top
 
Drant
Member Avatar

Try hiding the address bar from the ≡ icon (menu). Is it still the same color?
Are you sure your Java is the latest? What version of Windows are you using?

Right click the overlay window bar to show the context menu (the popup menu when you right click somewhere) and go to Colors > Load Theme. Try any of the themes 1-4 and see if the color changes, you can set the color yourself by choosing any of the "Set" choices.
Offline Profile Quote Post Goto Top
 
Azuredream
Unregistered

It is same color when hiding address bar.
Set options are not changing anything.
I run windows 7 x64 and updated Java to latest 2 days ago.
Guess I'll live with it now.
Quote Post Goto Top
 
Guest
Unregistered

I am so thankful that you still keep this updated. Seriously, thank you.
:cry:
Quote Post Goto Top
 
Drant
Member Avatar

I don't have Windows 10 and am not planning on upgrading to it anytime soon. If you are trying GW2Navi with the new OS, and encounter any problem, post here and I'll try to help.

The issue is with the overlay's dependence on Internet Explorer 11 to render/embed the website. I heard that IE is included in W10, but maybe Microsoft Edge will conflict with it. Anyway, I am thinking of changing the renderer to Chromium, eventually, which should be independent of W10.
Offline Profile Quote Post Goto Top
 
5argan
Unregistered

Hello,

I tried to run the overlay but I'm getting this error everytime I start up the jar. Posted Image

I updated my java to 1.8_51 (64 bit) and my IE to 11.0.9600.17959 and it doesn't work, neither did the IE11 fix help. I am running windows 7 x64 and I'm trying to run the win64 version of the overlay (the 32 bit version won't even start).

Any help is appreciated and I am happy to provide more information if I can.
Thank you in advance.
Quote Post Goto Top
 
Drant
Member Avatar

Is that a freshly unzipped instance (you didn't change anything on the overlay, except resized it to see the error message)?

Open options.ini and find
Code:
 
URL_HOMEPAGE = http://gw2timer.com/?mode=Overlay

and replace it with
Code:
 
URL_HOMEPAGE = http://example.com/


Does the overlay program not crash / view that website?

Also you can try changing
Code:
 
wantGPS = true

to
Code:
 
wantGPS = false
Offline Profile Quote Post Goto Top
 
5argan
Unregistered

Yes, it is a fresh zip file (I tried redownloading too just in case) but neither of your ideas changed anything.
Quote Post Goto Top
 
Drant
Member Avatar

Try opening the gw2timer.com website from your IE11 browser, does it work?

Can you try uninstalling IE11 (back to IE8 or whatever that was default for Windows 7), and installing it again?

Here are some multipurpose overlays you can use instead of mine:
GW2PAO - Tim's GW2 Tools - Overwolf Apps
Offline Profile Quote Post Goto Top
 
Charlene
Unregistered

Hi . nothing happens when i unzip the files also when i clicked the gw2 navi jar file just gives me an option to upzip the file
Quote Post Goto Top
 
Drant
Member Avatar

Did you install Java? Have you tried the troubleshooting instructions for .jar files?
Offline Profile Quote Post Goto Top
 
digitalsynner85
Unregistered

Hi, I use windows 10 and love the overlay so far. One thing I noticed is that I don't get sound when events are due to come up even though I have the alerts working in IE11 and chrome.
Quote Post Goto Top
 
digitalsynner85
Unregistered

Sorry (it wouldn't let me edit the post). In IE11 I don't get sound, but in chrome I do.
Quote Post Goto Top
 
Drant
Member Avatar

I use tts-api.com's service to generate an MP3 that IE11/Firefox plays. It looks like that service is down (even though the site is up). I haven't been using this feature since I've been using Chrome; do you know when this feature stopped working (if it did before)? I'm hoping this is a temporary problem that the tts-api.com admins will fix. If the downtime continues then I'll have to find an alternate TTS service.

As a workaround and if you really need the voice alarm, I suggest you use Chrome to open gw2timer.com for the alarm function, and use the overlay for the rest of the site's functions while playing GW2.
Offline Profile Quote Post Goto Top
 
digitalsynner85
Unregistered

It never did, at least not for me anyways. I'll do that though, thanks man.
Quote Post Goto Top
 
Drant
Member Avatar

I changed the TTS provider to ResponsiveVoice.JS. You should be hearing the same voice as Chrome's. Tell me if it's working and if you encounter any problems on IE11/Firefox/the overlay.
Offline Profile Quote Post Goto Top
 
digitalsynner85
Unregistered

Works perfectly now. I opened it up today to play and was like "oh shit there's sound now" lol
Quote Post Goto Top
 
onetwoeight
Unregistered

Hi! I tried using the overlay but it's telling me I'm missing a dll file and won't open. I tried all the troubleshooting and java updates but no luck. Is there anyway I can get that dll file? The one I'm missing is swt-win32-4510.dll and swt-win32.dll. The swt folder they were suppose to be in is empty. :c

Thanks.
Quote Post Goto Top
 
Drant
Member Avatar

If you open the .jar file with a ZIP opener like WinZip/WinRAR/7-Zip, you'll find the dll files on the top directory.

Here's the folder dll files as it should be in your directory:
Code:
 
C:\Users\YOUR_WINDOWS_USER_NAME\

Extract the .swt folder there.

I don't know why SWT didn't extract itself automatically when you first run GW2Navi. If this does not work then I suggest you reinstall Java then run the .jar again. Note that the GW2Navi bit version corresponds to the bit version of Java you installed, not your Windows bit version.
Offline Profile Quote Post Goto Top
 
Guest
Unregistered

The ovelay is not working for me today, was working finr before now. I am only getting the error page.
I have windows 10, IE 11 and java installed.
Quote Post Goto Top
 
Drant
Member Avatar

Please give me a screenshot of the overlay. It is likely the browser didn't download the latest JavaScript files so had null pointer exceptions. Click on the embedded browser/website and press F5, that should tell IE11 to refresh.
Offline Profile Quote Post Goto Top
 
Guest
Unregistered

It's the weirdest thing. For whatever reason it is now working again and I can't explain why.
I was getting the error message earlier that was a white screen that started with "If you are seeing this message..."
I reinstalled java and gw2overlay and nothing worked, but now it's suddenly working again.
Thanks for your reply.
Quote Post Goto Top
 
S1mul8r
Unregistered

Will you be adding the new API Key Management into GW2Navi? It would be very handy. :joyous:
Quote Post Goto Top
 
Drant
Member Avatar

Are you referring to these account information that are viewable with a browser? This feature is planned to be added to the site, but not soon.
Offline Profile Quote Post Goto Top
 
Guest
Unregistered

Is there a way to change the Trading Tracker items to english? For whatever reason, when I search for items, I can only find the items in french. This seems to be the only thing that use french in the entire app for me.
Quote Post Goto Top
 
Drant
Member Avatar

The Trading Tracker's search engine is English only because that's what the third party sites, gw2spidy.com and gw2shinies.com, provided (ArenaNet does not have an API for searching items). The TP app will be displaying items in English regardless of the site language you're on, so I do not know why you're getting French results. Can you give a screenshot?
Offline Profile Quote Post Goto Top
 
Guest
Unregistered

If I type Copper Ore and then click Enter, it opens me a a page in english, which is normal.
Posted Image

However, as shown below, my tracking is in french only.
Posted Image

I did make sure to select english as language in the compass, but that did not help.
Quote Post Goto Top
 
Drant
Member Avatar

Luckily I used two search providers, so the main one you're using (gw2spidy.com) might be serving you French results because your IP address... or something. Anyway, to use the backup search provider which is currently (gw2shinies.com), go to the "Options" page (cog icon), scroll down to "Trading" section and uncheck the option "Use main TP search provider".
Offline Profile Quote Post Goto Top
 
Guest
Unregistered

It seems changing my windows 10 language pack from French(Canada) to English(Canada) has fixed my issue.
Quote Post Goto Top
 
Lysla
Unregistered

I found out only today this stunning overlay app for GW2. Awesome job. I was wondering tho, the nodes for the *fixed* spots are perfect located, unlikely the "possible spots". This feauture have a lot of weak spots - lots of possible nodes not indicated and the indicated ones are almost never there.
There is app for gw2 (with overwolf for example) that arent even close to the quality of this one, but they offer a better service in precision terms - for routes of gathering stuff like all-the-iron-u-ca-find or all-the-softwood-u-can-find. Why so? Is it something you gonna work into?
In any case, gj again. :love:
Quote Post Goto Top
 
Drant
Member Avatar

Can you give a link to the Overwolf app you're referring to? That app may have more correct nodes because it's crowdsourced (the nodes are added by its users). For my map, I'm the only person who is adding the nodes, and the "possible nodes" are just that, places that I've seen the nodes spawned, which you may not find it there until you get the correct map instance (because they're randomly spawned in game).

I can add routes and more wood nodes, but they will not be added soon, because I have other things to work on right now.
Offline Profile Quote Post Goto Top
 
Lysla
Unregistered

I had no idea that actually this one was a one-person-project and I can understand how there is that lack of precision for nodes now. I was referring to many, ex. GW2 Map from OW or also GW2Nodes website itself - very well done but without a stunning project like yours. I know they use actually cooperative editing for inserting new nodes etc - but maybe you could "just" gather them all together or even think about a collaboration with the db from GW2 Nodes itself. Would be pretty awesome if it was possible generate the custom route for a full-iron-run and being dynamic like its your overlay ingame... Just wow. Just give a thought about it!
Quote Post Goto Top
 
Drant
Member Avatar

I have thought about adding every possible nodes from resource nodes sites like gw2nodes and orrmaps, but I felt overwhelmed. If people told me what resources they want to see more of, then I can prioritize which to add.

I can implement a function to automatically generate a route for the resources you have checked/visible. I cannot promise how soon it will be done though.
Offline Profile Quote Post Goto Top
 
Lysla
Unregistered

Drant
Saturday, 5. December 2015, 04:30
I have thought about adding every possible nodes from resource nodes sites like gw2nodes and orrmaps, but I felt overwhelmed. If people told me what resources they want to see more of, then I can prioritize which to add.

I can implement a function to automatically generate a route for the resources you have checked/visible. I cannot promise how soon it will be done though.
That would be great. I would say, at least personally, that the most frequent runs are for most of woods (soft wood, seasoned wood, hard wood) and iron/platinum. I'll keep an eye around here :)
Quote Post Goto Top
 
CrazyHobo
Unregistered

To be honest with you, I would really love to use your overlay but god damn is it confusing to use... is there like a video out there for the Internet Explorer?
also, when I use the gw2timer website on my chrome, I see waypoints, vistas and everything. In IE, I only see waypoints...
Quote Post Goto Top
 
Drant
Member Avatar

Did you read the manuals?

You need to turn the world completion option on first. Hover over the eye icon on the top right corner of the map, and checkmark the "Show completion" option. What are you confused about, so I can explain?
Offline Profile Quote Post Goto Top
 
Guest
Unregistered

hi just have to say i love this program works great but i just updated my java and now gw2navi is not working on both 32 bit and 64bit..its march 2016 not sure why its not working now...
Quote Post Goto Top
 
Drant
Member Avatar

What Java version did you install? You can find that number by going to the Windows Start menu and searching for "About Java".

When you say GW2Navi did not work, you mean it doesn't start (nothing appears) when you run it?

Can you try running GW2Navi from the command line and give a screenshot of the error if there are any?
Offline Profile Quote Post Goto Top
 
NerdDefender

I love this app, surprised there are not more members here after reading it about on the forums. My first question is, do you plan to continue to develop this program? I was using another overlay, but they stopped it so I had to look elsewhere and found this one (which I love too).

I love the ability to add bookmarks and check out sites within the program. I am getting crashes for the chromium version, so I am troubleshooting those, but overall it's great.

If I could be bold enough to add a suggestion. I like the art with the timers and it did take me a while to figure what a few of them were. I'm kind of minimalist and if you did continue to develop this program I would ask if you would think about something like this: http://www.timers.moongate.pl/. It's like the infamous HoT timers, but adds all the rest too (bosses & Drytop). Very useful for a quick glance. I know you have timer bars for HoT at the top of the screen, but they seem cramped and the buttons underneath are hard to see with the timers over the top.

I hate being that guy who makes requests, and I don't know if you are the sort who welcomes them or not, but I do enjoy this little program and that one feature would make it even better
Offline Profile Quote Post Goto Top
 
Drant
Member Avatar

I use the website almost exclusively and only use the overlay when I need to use the GPS feature. The overlay was created from repeated requests and I can see that hundreds of people use it daily (using Google Analytics), so I will keep maintaining it for the time being. The highest priority plan is to convert it to the Chromium version, but the desire to have both working 32 and 64 bit version, and to have the audio notification works (mp3 filters for the Chromium engine) have been obstacles.

The HoT timeline was designed to be compact and non-redundant; the website you linked takes nearly my entire monitor's space. Regarding the world boss timers and Dry Top map style timers, I assume people who do those do them separately and not hopping between doing WBs and Dry Top then HoT maps. That is, I assume people do HoT maps exclusively during their playtime and not WBs and Dry Top also too; which is why they are separated as the timeline on the map panel, and as the chain bars on the right panel.

The website and overlay you see is the result of about 75% my ideas, and 25% users'. So of course feedback is appreciated. I need to know how you use the timeline if I am to implement them (additional lines on the timeline). Where do you position the overlay, what other stuff do you do or want to do while you have those timeline open. Perhaps a screenshot of your game screen setup?
Offline Profile Quote Post Goto Top
 
fang
Unregistered

Hey i have been trying to get the app to work but it never launches. I have done all the trouble shooting that you have suggested but none have worked.
Quote Post Goto Top
 
Drant
Member Avatar

Is this your first time running the overlay, or you could run it before but it doesn't work now? What operating system are you using?

Have you tried the Chromium version? Does that work?

Can you open the Windows Start menu and search for "About Java", what version and build number does it say?

Try running the .jar file from your Command Line and tell me what error it gives.
Offline Profile Quote Post Goto Top
 
6 users reading this topic (6 Guests and 0 Anonymous)
ZetaBoards - Free Forum Hosting
Enjoy forums? Start your own community for free.
Go to Next Page
« Previous Topic · GW2Timer.com - GW2 - Guild Wars 2 · Next Topic »