Welcome Guest [Log In] [Register]
Error on Load/Unload
Topic Started: Monday, 28. August 2017, 02:39 (994 Views)
Tubbs
Member Avatar

When loading in 2d or 3d i receive this error: options.ini was unable to be saved! :???:

i cant seem to find anything on this under troubleshooting.

Any help is appreciated.
In the land of the blind the man with one eye is king.
Offline Profile Quote Post Goto Top
 
Drant
Member Avatar

What is the full folder path of where you put the GW2Navi folder? It should not have special symbols in the name.

Does the overlay work? Or that message shows up and nothing else happens? If so then try the "Overlay won't start or javaw not found." troubleshooting method.
Offline Profile Quote Post Goto Top
 
Tubbs
Member Avatar

The overlay works, the error just pops up when loading , and exiting.

Ill try your recommendations once i get home ty.
In the land of the blind the man with one eye is king.
Offline Profile Quote Post Goto Top
 
Tubbs
Member Avatar

Drant
Monday, 28. August 2017, 06:06
What is the full folder path of where you put the GW2Navi folder? It should not have special symbols in the name.

Does the overlay work? Or that message shows up and nothing else happens? If so then try the "Overlay won't start or javaw not found." troubleshooting method.

I cant edit the file says i need to "contact Admin" i uninstalled/reinstalled Java, still getting the error.
In the land of the blind the man with one eye is king.
Offline Profile Quote Post Goto Top
 
Drant
Member Avatar

Are you using your own computer? That .bat file is just a text file. Open the Notepad application then use that to open the .bat file. If you can't edit it, then just tell me where your javaw.exe file is and I'll make a new .bat file for you. For example, go to the folder:

"C:\Program Files\Java\jre1.8.0_144\bin\" and "javaw.exe" should be there, assuming you're running 64 bit and installed the 64 bit Java (jre-8u144-windows-x64.exe).

Example of new .bat file:
Code:
 
@echo off
start "" "C:/Program Files/Java/jre1.8.0_144/bin/javaw.exe" -cp "bin/*;bin/GW2Navi_Win64.jar" -Djava.library.path=./bin/lib/libcef/win64 GW2Navi.Main
Offline Profile Quote Post Goto Top
 
Tubbs
Member Avatar

Drant
Tuesday, 5. September 2017, 11:58
Are you using your own computer? That .bat file is just a text file. Open the Notepad application then use that to open the .bat file. If you can't edit it, then just tell me where your javaw.exe file is and I'll make a new .bat file for you. For example, go to the folder:

"C:\Program Files\Java\jre1.8.0_144\bin\" and "javaw.exe" should be there, assuming you're running 64 bit and installed the 64 bit Java (jre-8u144-windows-x64.exe).

Example of new .bat file:
Code:
 
@echo off
start "" "C:/Program Files/Java/jre1.8.0_144/bin/javaw.exe" -cp "bin/*;bin/GW2Navi_Win64.jar" -Djava.library.path=./bin/lib/libcef/win64 GW2Navi.Main


Using my own computer, spent awhile trying to figure that out, I'm the only User on this computer lol, I ended up saving the file to another folder and copied it and placed it here - C:\Program Files\GW2Navi-master\bin

Still getting the error, "Run as admin" wont open it.
In the land of the blind the man with one eye is king.
Offline Profile Quote Post Goto Top
 
Drant
Member Avatar

Can you give me a screenshot of the error?

Where is your javaw.exe file?

What is the content of your GW2Navi_Start_2D.bat file?
Offline Profile Quote Post Goto Top
 
Tubbs
Member Avatar

Drant
Wednesday, 6. September 2017, 10:57
Can you give me a screenshot of the error?

Where is your javaw.exe file?

What is the content of your GW2Navi_Start_2D.bat file?



C:\ProgramData\Oracle\Java\javapath

@echo off
start javaw -cp "bin/*;bin/GW2Navi_Win64.jar" -Djava.library.path=./bin/lib/libcef/win64 GW2Navi.Main

Attached to this post:
Attachments: 2017_09_06.gif (87.93 KB)
In the land of the blind the man with one eye is king.
Offline Profile Quote Post Goto Top
 
Drant
Member Avatar

C:\ProgramData\Oracle\Java\javapath is not the path we want.

Can you go to the folder "C:/Program Files/Java" ?
In there, is there another folder named "jre1.8.0_144" or something like that?

For example "C:/Program Files/Java/jre1.8.0_144/bin/" is where your javaw.exe should be. Can you find it?

If you downloaded the latest Java version as of today, you can replace the contents of GW2Navi_Start_2D.bat with:
Code:
 
@echo off
start "" "C:/Program Files/Java/jre1.8.0_144/bin/javaw.exe" -cp "bin/*;bin/GW2Navi_Win64.jar" -Djava.library.path=./bin/lib/libcef/win64 GW2Navi.Main
Offline Profile Quote Post Goto Top
 
Tubbs
Member Avatar

Wont let me save i get this error (attached). The javaw file is where you said it should be, I can not save the replacement code.

I'm sorry for all this trouble, I like the overlay, just new to the game and having a hard time understanding all this, I don't mean to be any trouble.


So I solved the error from being able to save (replacement code) by following these directions:

Let’s give permission to the file and check if that helps. Follow these steps to give permissions to the drive.
a)      Right-click on the file which you’re unable to access and select Properties.
b)      Click on ‘Security’ tab and under ‘Group or user names’ click on ‘Edit’.
c)       Click on ‘Add’ and type ‘everyone’.
d)      Click on ‘Check names’ and then click ‘OK’.
e)      Select ‘everyone’ and under ‘Allow’ select ‘Full control’ and click on ‘Apply’ and Click ‘Ok’.
 

I am still getting the original error: "options.ini was unable to be saved!" when loading/unloading the overlay.
Attached to this post:
Attachments: 2017_09_07.png (29.97 KB)
Edited by Tubbs, Friday, 8. September 2017, 00:14.
In the land of the blind the man with one eye is king.
Offline Profile Quote Post Goto Top
 
Drant
Member Avatar

I think it may be a problem with Windows 10 and its extra security settings. You can try something like the directions you posted. Apply the new permissions to:
- GW2Navi folder
- options.ini file
- bookmarks.txt file (optional)
- translations.ini file (optional)

I attached the modified .bat file below with the path to javaw.exe included.

I don't use Windows 10 and never expected this much hassle for players on that OS. If you still can't get GW2Navi to work, here are other good multipurpose overlays to use instead.
Attached to this post:
Attachments: GW2Navi_Start_2D.bat (159 Bytes)
Offline Profile Quote Post Goto Top
 
Tubbs
Member Avatar

Drant
Friday, 8. September 2017, 10:32
I think it may be a problem with Windows 10 and its extra security settings. You can try something like the directions you posted. Apply the new permissions to:
- GW2Navi folder
- options.ini file
- bookmarks.txt file (optional)
- translations.ini file (optional)

I attached the modified .bat file below with the path to javaw.exe included.

I don't use Windows 10 and never expected this much hassle for players on that OS. If you still can't get GW2Navi to work, here are other good multipurpose overlays to use instead.
Giving full permission to the GW2Navi Folder via the instructions I posted worked!!!

Thanks again for all your help!
Edited by Tubbs, Friday, 8. September 2017, 23:04.
In the land of the blind the man with one eye is king.
Offline Profile Quote Post Goto Top
 
Drant
Member Avatar

Thanks for not giving up. I'll add that solution to the troubleshoot.
Offline Profile Quote Post Goto Top
 
1 user reading this topic (1 Guest and 0 Anonymous)
« Previous Topic · GW2Timer.com - GW2 - Guild Wars 2 · Next Topic »